Intel SSD 520×2台のRAID0で爆速化(Windows7&Z77チップセット)

弟がパソコンのスピードを速くしたいということで、SSD×2台でRAID0を組むことを薦めてみた。

現在では最新のIntel Z77チップセットを搭載したマザーボードと、SATA3(6Gbps)対応のIntel SSD520 120GB×2台を購入し、以下の構成でベンチマークを行ってみました。

OS Windows7 Home Premium SP1 64bit
CPU Intel(R) Core(TM) i7-2700K CPU @ 3.50GHz
メモリ DDR3 8GB
M/B ASRock Z77 Extreme4-M
SSD Intel SSD 520 120GB (SATA3)

まずはSSD単体でベンチマーク。

Single

さすが、SATA3(6Gbps)対応ということもあって単体でもかなりのスピード。

そして、RAID0(ストライプサイズ128k)でベンチマーク。

RAID0

約2倍のスピード!Windows7の起動がBIOS画面終了から10数秒で起動完了。

電源ボタンを押してBIOSの画面表示も含めても30秒以内に起動が完了した。

 

しかし、インテル(R) SSD 520 シリーズ リリース記念 プレミアムレビューという記事によると、秒速1ギガ(1GB/s)出るというのを見た。今回のハードウェア構成の方がハイスペックなのに秒速1ギガ(1GB/s)出なかったので、ちょっと残念なのと以下の疑問が残る...。

  • システムドライブとデータ用ではスピードが異なるのか?
  • ストライプサイズは64kくらいに変えると速くなるのか?
  • 4台でRAIDを組むとどれくらい速くなるのか?
  • システムドライブとしてRAIDを使うならクリーンインストールする方が速いのか?

※今回は単体のSSDで使用していたシステムドライブのバックアップを、RAIDボリューム復元にしてベンチマークを行なっています。RAIDへの移行は、移行前にレジストリの変更をしないと、移行してもWindowsが起動しません。移行方法は クリーンインストールなしてRAIDへ移行する方法:Windows VISTA/7/8 を参照してください。

 

2012/05/16追記

RAID0のストライプサイズを128kから64kに変更し、表示が一部正常に表示できていなかったインテル ラピッド・ストレージ・テクノロジーを再インストールすると、正常に表示できるようになり、RAIDボリュームのキャッシュが無効になっていたので、有効にして再度ベンチマーク。

インテル ラピッド・ストレージ・テクノロジー

すると更に速くなりました。

SSD_RAID0キャッシュ有効

しかし、シーケンシャルリードが1000MB/sを超えられなかったのが残念です。

 

2013/01/25追記

RAID0は不安定だと聞いていましたが、PCで起動時に表示されるRAID BIOSでエラーが出るようなりました。

エラーが表示されるものの、Windows7は通常通り起動します。ですが不安なので、その度にインテル・ラピッド・ストレージ・テクノロジー(IRST)で修復を行なっていました。Ver.11.5くらいからは、自動で診断と修復のスケジュールを設定きるようになったので、それからは安定しています。ちなみにRAID環境では使えなかったTRIMが有効になるため、Intel SSD ToolboxのIntel SSD OptimizerでTRIM機能が使えるようになりました。

インテル ラピッド・ストレージ・テクノロジー

ただ、Ver.11.7をインストールしたところ、インテル・ラピッド・ストレージ・テクノロジー(IRST)自体が起動できない現象が起こったので、Ver.11.5をインストールしたら正常に起動できました。

「ラピッド・ストレージ・テクノロジー 11.5」と検索すれば、PCメーカーのサポートサイトがヒットするので、そこからダウンロードできます。ちなみに僕の場合はレノボのサイト(http://support.lenovo.com/ja_JP/downloads/detail.page?DocID=DS032146)からダウンロードしたました。